DeadEd.com
IRC Bots, Java Game Query and Control Libraries, and More ...
Sign Up!
Login
Welcome to DeadEd.com
Monday, August 21 2017 @ 01:25 AM CDT

 Forum Index > Jibble.org > PircBot
 Messages are delayed even if getMessageDelay() is low
 |  Printable Version
By: dotintegral (offline) on Wednesday, October 05 2011 @ 02:07 PM CDT (Read 9593 times)  
dotintegral

Hi.

 

I've got the following poroblem.

I've set the messageDelay property using setMessageDelay to 10ms. When I send multiple messages at once through the sendMessage() method, let's say 10, the first 5 or 6 messages appear instantly, but next are queued and sent with a delay of 1000 ms or so. I don't know why it happens, I haven't found anything similar in the pircbot documentation. I would like send all of the 10 messages instantly. I'm aware of that it's not safe to send a lot at once, but I can handle it.

 

Thanks in advance for any help.


Forum Newbie
Newbie


Status: offline

Registered: 10/05/11
Posts: 2

Profile Email    
   
By: dotintegral (offline) on Saturday, October 08 2011 @ 03:34 AM CDT  
dotintegral

Hi again.

 

It took me a while, but I've managed to find the reason of my problem and it is ... the IRC server. Seems that Quakenet's servers have somekind message queue on their own. I was mistaken and just assumed it was a pircbot's hidden feature. I'm glad I've found this ;-)


Forum Newbie
Newbie


Status: offline

Registered: 10/05/11
Posts: 2

Profile Email    
   



 All times are CDT. The time is now 01:25 AM.
Normal Topic Normal Topic
Locked Topic Locked Topic
Sticky Topic Sticky Topic
New Post New Post
Sticky Topic W/ New Post Sticky Topic W/ New Post
Locked Topic W/ New Post Locked Topic W/ New Post
View Anonymous Posts 
Able to Post 
Filtered HTML Allowed 
Censored Content 

My Account





Sign up as a New User
Lost your password?

What's New

Stories

No new stories

Comments last 2 days

No new comments

Files last 14 days

No new files
No new comments

Links last 2 weeks

No new links